Time Approval page is not loading
Incident Report for Rise People
Resolved
This incident has been resolved.
Posted Nov 07, 2024 - 14:01 PST
Monitoring
A fix has been implemented addressing the underlying issue and recovery has been observed. We continue to monitor the situation.
Posted Nov 07, 2024 - 13:41 PST
Identified
Reports that the Time Approval page fails to load have been investigated and the issue identified. Our teams are working towards a resolution.
Posted Nov 07, 2024 - 13:12 PST
This incident affected: Scheduling and Time Tracking.